1008HA step by step OS X installation (w 10.5.8)

Discussions of other Netbooks

1008HA step by step OS X installation (w 10.5.8)

Postby ikeny » Fri Jul 10, 2009 10:42 am

I have been using my Lenovo S10 as a Mac (hackintosh) netbook for over 3 months. As much as it worked very, being able to perform all the task I need just as well as my MacBook, I've never been a big fan of the weight and appearance of the S10. I've decided it's time to try something new. I ended up selecting the ASUS Eee pc 1008HA for its slim form factor and light weight.

Not being able to stand Windows, my quest to hackintosh this baby begins...
Overall, I am impressed with the results -

10.5.8 with all updates installed
Screen brightness, sound (speakers, headphone), volume control;
Sleeps on closing lid; need to press power button to wake, and adjust screen brightness to turn on backlight (there is fix for that in 2nd post below);
Need to replace wifi card for wifi to work;
Ethernet via Apple USB ethernet adapter
Tethering with my iPhone works (USB and BT)
Tackpad with tapping, 2-finger scrolling, right click with 2-finger tapping
Bluetooth works. Tethering with iPhone via Bluetooth works!

On board LAN
Mic (?)
wifi with the original wLAN card


This is the procedure that I used for the installation of OS X as the only partition and OS. Because I like the installation to be as vanilla as possible, I use a DVD drive and retail Leopard DVD. Also, this method required me to wipe the entire HDD and partition it under GUID. OS X will be your only OS, although you can put Windows 7 later as a dual boot. (see the bottom half of my other guide)

I started with some dowloads with another working Mac or PC.

a)DellMiniBoot123v8.01 (for 10.5.5 DVDs and below) - http://redirectingat.com/?id=258X408&ur ... 01.iso.zip
DellMiniBoot123v8.02b1 (for 10.5.6 DVDs and above) - http://redirectingat.com/?id=258X408&ur ... b1.iso.zip

b) download the combo 10.5.8 update
http://support.apple.com/downloads/Mac_ ... mbo_Update

c) DellEFI1.1.zip

d) kext files used in the following steps

e) dsdt.aml patcher GUI
http://ihackintosh.blogspot.com/2008/12 ... pcwiz.html

Part 1
Pressed F2 at start up to enter BIOS. Turned off CPU hyperthreading. Also changed the boot order so it'll boot off a DVD drive first.

Burned DellMiniBoot onto a CD (with another computer) and booted from it
-> Esc, replaced with Leopard DVD, and entered ef, hit enter once, and then F8
- at the prompt typed the following to force the resolution to fit (enter as is with quotations), '-v' to show the boot progress
"Graphics Mode"="800x600x32" -v

Leopard installation started up in about 5 min. Before Installation, went to Disk Utility.
-> Partition, change Current to 1 partition. Under Option, select GUID
Named my drive or new partition as "osx"

The installation began, and took about 30 minutes. At the end of the installation, it displayed an error page. I forced shut down by pressing and holding the power button.

Part 2

Restart by booting again with DellMiniBoot CD again, but this time read the HDD instead of Leopard DVD
-> Esc, 80, enter, "Graphics Mode"="800x600x32" -v, enter

The OS X setup page appeared in 5-10 minutes. I followed it though, and it hang at the Migration Assistant page. (this was fixed after I replaced the wifi card with Dell 1510)
I forced shut down by holding the power button, booted from DellMiniBoot CD again ->Esc, 80, enter (once) then boot into single user mode (boot option is "-s" before enter): i.e.,
"Graphics Mode"="800x600x32" -s

I entered the following exactly as shown, one line at a time:

/sbin/fsck -fy
/sbin/mount -uw /
cd /Volumes/osx/var/db/ (or just: cd /var/db/)
touch .AppleSetupDone
(to set root password:)
passwd (enter password two times)

exit (to continue booting into OS X)

It should boot into OS X for the first time.
Log in as root, with you newly created password.

Move the 10.5.8 combo update to your desktop, and install it. (The last part, writing script, took a long time to finish)
It rebooted (with DellMiniBoot, enter, 80, enter) 2 times. By patient, it took 5 - 10 minutes to shut down or restart.

After finally booted into 10.5.8, moved DellEFI1.1 on your desktop.
Right click, Show Package Content
Navigate to /Content/Resources/Extension
Remove RealtekR1000.kext and IOSDHCIBlockDevice.kext as they are for Dell Mini's LAN and SD card reader

Add Voodoopower.kext and VoodooUSBEHCI.kext
I got these from http://www.superhai.com/darwin.html
(could also use Voodoopowermini.kext instead of Voodoopower, google for it. Either one let the CPU speedsteeps. The mini version is a "cleaned up version designed for Dellmini9 but also works on the 1008HA)

Also removed AppleACPIPS2Nub.kext and ApplePS2Controller.kext
(They need to be removed for VoodooPS2Controller installation next)

These were the kexts in my extenstion folder:

Now run DellEFI1.1 by double clicking it.
-> Yes (to confirm). Select Custom installation.
Install, with only the first two selected: Chameleon Bootloader, Mini 9 Extensions (Do not restart just yet when you are doing, just quit DellEFI)

Downloaded VoodooPS2Controller.pkg installer from
http://chameleon.osx86.hu/file_download ... taller.pkg
Ran installer, checked the trackpad option.

Restarted, took 5+ minute.
After restart, I got both Trackpad and VoodooPS2 in preference pane. 2-Finger scrolling needed to be selected in both for it to work.

Part 3
Now off to setting up your OS X (it's easiest to do this while logged on as root)

3a) Installed dsdt.aml patch (this patch will speed up your computer boot time)
downloaded the patch from
http://ihackintosh.blogspot.com/2008/12 ... pcwiz.html
Ran it, with "Apply dsdt patch to" checked.

3b) Wifi: you need to replace the stock card with the following Dell card (can be order online from Dell.com or Dell.ca)
2.4/5 GHz Wireless 1510 PCI Express Internal WLAN Half-Height Mini-Card for Dell Studio 17 Laptop

3c) Saving Voodoo Trackpad setting and Keyboard Map fix
My VoodooPS2 preference setting was not saved upon restart. Followed this thread, downloaded and installed the .plist file:
http://forum.voodooprojects.org/index.p ... 567#msg567
(I downloaded and used the org.voodoo.trackpad.configurationloader.plist without making any modifications)

[Update] Issue with keyboard mapping: the "~" was mapped to a funny character after the installation of VoodooPS2. To fix this, I used Ukelele (google for it). Open it up, use copy of an existing layout, and use the swap function to create a new keylayout file. (you can PM one with your email, and I can send it to you)
You just need to place it in /Library/Keyboard Layouts
Restart. Go to international, find it and select it.

3d) Audio fix: there are two methods available. I tested the Method 1, not Method 2

Method 1 (from Carlos again) using AzaliaAudio
Delete the AppleHDA.kext from /extensions
Install AzaliaAudio.pkg -- http://www.mediafire.com/?enez1guzz1g
Install CHUD tools -- http://www.mediafire.com/download.php?mzjlkm4idyb
Audieee_1.0.1.zip -- download/file.php?id=65
Put the file in /Applications/Utilities and run it. Audio works now; use menubar icon to toggle (default is off). Add the Audieee application to your startup items.

Method 2 VoodooHDA
A new VoodooHDA kext for audio fix (speakers AND mic) is available. It is still buggy, and sleep tends to create issue. However, you don't need to manually switch between speakers and headphones.

3e) Testing quick sleep, shut down and dsdt.aml

Go to Terminal, enter the following to make sure your HA is set for quick sleep -
sudo pmset -a hibernatemode 0
Try closing the lid, or press Fn+F1, to see if it sleeps. To wake it up, open the lid, press any key, and Fn+F6 to turn on back light. (there's a fix to automatically turn on the screen backlight, see Post #3 below)

In my case, my HA could not sleep (wifi button stayed on). I had to remove the dsdt.aml file, rebooted (the slow way). Now it can sleep.

That's all for now. Finally, you should run OS X's own Software Update.
Now create a new user account, so you don't always log in as root.
You do not have the required permissions to view the files attached to this post.
Last edited by ikeny on Mon Aug 10, 2009 10:03 am, edited 21 times in total.
Posts: 217
Joined: Sun Mar 08, 2009 3:17 pm
Color and Model: S10 + OCZ Vertex SSD + OCZ Vista RAM
OS(s) installed: Leopard 10.5.6 + Windows 7


Post #2: Bluetooth fix and tethering

Postby ikeny » Sun Jul 12, 2009 4:18 am

The following was written for my 1008HA, but should work on other hackintosh netbook/notebooks too.

A) Tethering via USB

Turn on tethering on your iPhone, connect iPhone to computer via USB, following on screen instruction to go to preference.

If this is the first time you set up any network access on this computer; i.e., no entries inside the column of the left side of the network page, then you should do the following: Select Location at top of window, edit Location, +, type in Automatic.

Now on the left side, click +, you should be able to add something like Ethernet Adaptor (en 0).
On the right side, if IP address was not already picked up, deselect DHCP, apply and reselect DHCP, apply.

Happy surfing!!

B) Tethering via bluetooth

This is quite a bit more complicated, because bluetooth doesn't work 100% out of the box on hackintoshes. I need to do 2 fixes.

Fix #1 - grayed out "ON" checkbox

Go to "About this Mac, More Info", look for information of your bluetooth hardware, specifically the HEX code for Product ID and Vendor ID.

For 1008HA, look for BT-253 under USB -
Product ID: 0xb700
Vendor ID: 0x0b05 (ASUSTek Computer Inc.)

Google for a HEX to Decimal converter, in my case b700 and 0b05 convert to 46848 and 2821. Note these two numbers.

Next log in as root, open this file with textedit - /System/Library/Extensions/IOBluetoothFamily.kext/Contents/

(you need to right click, "show package content" a couple of times to access the file)


Replace 8448 with 46848; 2652 with 2821. That's it. Just manually clear kext caches before restart
(in Terminal)
sudo rm /System/Library/Extensions.mkext
sudo rm -r /System/Library/Caches/*
sudo touch /System/Library/Extensions

Now you should be able to pair your computer with iPhone.
Go to - Setup Bluetooth Device, follow the on screen instructions.
After pairing it's done, it won't automatically connect, you need to select "Connect to Network". If it can't stay connected, try restarting (more to following in Fix #2).

Now go the the Network page of Preference. You see see a new connection of "BluetoothPAN", config it to DHCP, and you are done!

Fix #2 - Connection issue to my iphone after sleep
If your "Connect to Network" under bluetooth is grayed out after sleep, you need the following fix.

Credit of the following goes to this website:
http://mydellmini.com/forum/mac-os-x/85 ... sleep.html

1. Scroll to Post #8 on page 1, follow links to download blueutil and sleepwatcher

2. Install blueutil
(your bluetooth should be on and working)

- double click blueutil.dmg
- click and drop blueutil to Desktop
- open Terminal
cd Desktop
sudo cp blueutil /usr/bin
(type in passwd to verify)

(to turn on blueutil)
blueutil on
(and to check the status)
blueutil status

3. Install Sleepwatcher
- open the .dmg
- run both installers, sleepwatcher and its startupitem

4. edit two files -

(in terminal, go to /etc)
cd /etc

(copy the files onto your desktop, replace "Xyz" with your login name)
sudo cp rc.sleep ~Xyz/Desktop
sudo cp rc.wakeup ~Xyz/Desktop

(now open the files with TextEdit, and add to the very bottom the following)
In /etc/rc.sleep, place the following 3 lines at the end:
/usr/bin/blueutil off
sleep 1
/sbin/service com.apple.blued stop

In /etc/rc.wakeup, place the following 3 lines at the end:
/sbin/service com.apple.blued start
sleep 1
/usr/bin/blueutil on

(save and close TextEdit)

(now copy the files back to replace the originals)
cd ~Xyz/Desktop
sudo cp rc.sleep /etc
sudo cp rc.wakeup /etc

Restart, now when you sleep the 1008HA, you should see the bluetooth icon flash to grey before the screen shuts off.
Last edited by ikeny on Fri Aug 07, 2009 2:17 pm, edited 3 times in total.
Posts: 217
Joined: Sun Mar 08, 2009 3:17 pm
Color and Model: S10 + OCZ Vertex SSD + OCZ Vista RAM
OS(s) installed: Leopard 10.5.6 + Windows 7

Post #3: Fix the Brightness controls after wake

Postby ikeny » Thu Jul 23, 2009 5:52 pm

Go to http://www.eeeboot.org:/

Scroll down and following the section -
Fix the Brightness controls for wakeup and Ethernet.

*First you need to have sleepwatcher installed. Read the post above this.

It involves downloading EEEboot.iso file and running one part of it (Set up wake).
Unfortunately the ethernet fix doesn't work for 1008HA. You could go into /etc/rc.wakeup and /etc/rc.sleep and remove the lines regarding ethernet; i.e.,
- leaving only /etc/rc.DIMsleep in the rc.sleep
- leaving only /etc/rc.DIMwakeup in rc.wakeup

Finally, don't forget to do the last step as instructed -
in terminal, type
sudo touch /etc/last_brightness
sudo chmod a+w /etc/last_brightness
Last edited by ikeny on Fri Jul 31, 2009 10:08 am, edited 1 time in total.
Posts: 217
Joined: Sun Mar 08, 2009 3:17 pm
Color and Model: S10 + OCZ Vertex SSD + OCZ Vista RAM
OS(s) installed: Leopard 10.5.6 + Windows 7

Post #4: deep sleep ?

Postby ikeny » Fri Jul 31, 2009 10:07 am

My battery is draining at a rate of 5+ % per hour during quick sleep, and so I really want to find a way to perform a deep sleep.

I can enable deep sleep (mode 1) in Terminal:
sudo pmset -a hibernatemode 1

The computer will deep sleep, about upon wake, Chameleon cannot read the sleepimage file, and ends up restarting.
(Note - previously I used DellEFI1.2a5 and wasn't able to deep sleep, always went to quick sleep)

I read about a patched version of latest Chameleon (ver 2.0RC2) from the MSIWind forum. Tried it, but still no success. I'll update this when I have more information.
Posts: 217
Joined: Sun Mar 08, 2009 3:17 pm
Color and Model: S10 + OCZ Vertex SSD + OCZ Vista RAM
OS(s) installed: Leopard 10.5.6 + Windows 7

Post #5: 10.5.8 and other updates

Postby ikeny » Thu Aug 06, 2009 1:32 pm

My HA was initially installed with just 10.5.7. I tried updating to 10.5.8, but after that, it cannot find my wifi card (No airport card installed). I search the web for a few days but could find anything. At the end, I did a fresh installation, updated to 10.5.8 (no issue at all), and THEN performed the DellEFI installation and other fixes. It worked much better. The guide in the first post was already updated with this fresh installation to 10.5.8.

After 10.5.8, all other OS X updates installed natively without any problems:
"Java for Mac OS X 10.5 Update 4" (1.0)
"AirPort Utility Software Update 2009-002" (5.4.2)
"AirPort Utility" (5.3.2)
"iTunes" (8.2.1)
"QuickTime" (7.6.2)
"Front Row Update" (2.1.7)
"iPhoto Update" (7.1) to (7.1.5)
"Safari" (4.0.3)
"Security Update 2009-004" (1.0)

I discovered a minor issue with the battery icon not displaying properly. It is showing 'Power Adapter' as the power source even when running on battery. The remaining battery time is not showing. Under the Energy Saver Preference, it no longer has the 'battery' and 'power adapter' modes.

This is reported in the Dell mini forum, not surprising as I am using DellEFI installation approach.
http://www.mydellmini.com/forum/mac-os- ... ports.html

I'll update once I see a solution.

Here is the solution:

Download patched AppleSMBIOS.kext from here:
http://www.mydellmini.com/forum/mac-os- ... #post90547

Put the patched AppleSMBIOS.kext in /Extra/Mini9Ext

Delete the original AppleSMBIOS.kext from /Systems/Library/Extensions (back it up first just in case)

UpdateExtra and restart
Now I have both the 'battery' and 'power adapter' profiles back :)
Posts: 217
Joined: Sun Mar 08, 2009 3:17 pm
Color and Model: S10 + OCZ Vertex SSD + OCZ Vista RAM
OS(s) installed: Leopard 10.5.6 + Windows 7

Return to Other Netbooks

Who is online

Users browsing this forum: No registered users and 1 guest